No SIM?

Go to solution
Highlighted
Not applicable

No SIM?

Bought an iPhone XR from virgin mobile's website and have an unlimited data plan with them. Phone has been working fine since the purchase around a week ago. Until today, when I look at my lock screen and it says NO SIM CARD. I check my account on the virgin mobile website and it looked like the photo I attached... no idea what is happening rn. virgin mobile down.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Agent

Hello, klice315! We are sorry about the issues you're having. We'd like to look into this for you. Can you send us a private message with your phone number and pin code to verify your account?

View solution in original post

11 REPLIES 11
Highlighted
Agent

Hello, klice315! We are sorry about the issues you're having. We'd like to look into this for you. Can you send us a private message with your phone number and pin code to verify your account?

View solution in original post

Highlighted
Not applicable

Hello,
I am having the same problem on an iPhone 6- I took it to an apple sttore and they said the problem is with the SIM card, not the device. Is it possible to have this issue resolved at a sprint store? I cannot make phone calls to customer service without the sim.
Highlighted
Agent

Hello, Nhill1990. We are sorry about the issues you're having. We'll be happy to assist you with that. Can you send us a private message with your phone number and pin code to verify your account? Thanks.

Highlighted
Agent

We have replied to your private message, Nhill1990. Please check your inbox. Thanks.

Highlighted
Not applicable

I'm having the same issue NO SIM. Where is the solution?

Highlighted
Not applicable

The simple fix that worked for me was to just remove and reinsert the SIM card.

Highlighted
Agent

Hi there, @demthompson! Please, send us a private message with more details about the issue to further investigate. 

Highlighted
Not applicable

How do I send a private message?

Highlighted
Agent

Hi, @demthompson. You can click on my profile and choose the option "Send this user a private message".