Galaxy S8 can not send/receive MMS or use mobile data

Enthusiast

Galaxy S8 can not send/receive MMS or use mobile data

For nearly a week I have not been able to use my mobile data or send/receive MMS. I have tried resetting the phone, clearing caches, using the ##72786# reset, and resetting the network. Nothing is working and I am missing important messages from my employees and vendors. My account is completely up to date so there should be no reason I cannot use my mobile data. Ever since the merger I have had issues with my phone and service.

109 REPLIES 109
Agent

Hello, @Girnade. Thank you for stopping by. Please send us a private message to further assist you. We'll be waiting for your response. Remember, we're here to help. -Kira_M.

Enthusiast

Edmonds
I've been a customer with Boost for about a decade now. I've never had issues with my galaxy s8+ until now. When someone just buys a phone from you everything should work without excuses; we rely on that. It's not acceptable for your phones to be unable to send MMS without correction whether one had just bought their phones and wants to use your service. Would you accept that? I've had my Galaxy 8+ for about 2 years with no issues until now. A couple weeks ago this happened and I did a factory reset successfully. This is not a phone issue. This is a network issue. Value your customers who've been with you faithfully, and have repeatedly recommended Boost. Now, I don't know if I can anymore. Please fix this.
Agent

Hi there, Karinklc38! We're aware of this issue affecting several customers and our network engineers are currently doing all they can to have it resolved as soon as possible. A known workaround is going into Settings > Mobile Networks > Network mode > Select CDMA. This will switch the phone to 3g. You can change this setting at any time. Let us know if the issue persists while on 3g.

Enthusiast

Hello, same issue here.  MMS messages are not sending/receiving on WiFi or 4G for past several days.  I can PM details, can you help to resolve this please?

Agent

Hello, BA22. Please send us a private message with your phone number and PIN.

Groupie

I have been having this exact same issue since July! Boost has been giving me the runaround and I have tried every code and even did a factory reset!! It still won't work right! They kept blaming Samsung until I took my phone there and had a diagnostics ran on it and was told it was BOOST's NETWORK!! When I called and told them they argued with me assuring it was not the case or my phone would not work at all!! There's a lot more to this issue but you get the point. I am drained and tried getting another service, long story short Boost would NOT unlock my phone because I haven't had it for a year yet!!! I asked them what difference does it make if I pay it off and they told me it's their policy!! I am beyond LIVID and ready to take matters to a more serious step!!

Enthusiast

I have been having the same problem for a couple of weeks., suddenly unable to receive or send MMS messages on two different Samsung Boost phones that I've been using without problems for a couple of years. 

 

I have found a solution that works on both my Galaxy J7 Perx phone and my Galaxy S8 phone.  Here's what worked for me, so that I can now receive MMS messges and ALSO keep my 4G LTE service (with the network mode set back to "automatic" instead of the slower "CDMA," which I had to use for the weeks before I figured this out).

 

The solution for both phones involved going into "Settings" and turning on "Developer Mode."  This opened up a  "Developer Options" category in the Android Settings, which allowed me to toggle on a switch called "Keep Mobile Data turned on - Keep Mobile data turned on at all times, even while WiFi is in use, to make it quicker to switch networks."  

 

Once I had toggled this switch "on," I went back to "Connections / Mobile Networks" and reset the network mode to "Automatic."  When the phone restarted, I once again had 4G LTE service and my MMS messages were working as they have for years.

 

This is how I turned on "Developer" Mode on each of my phones.  Perhaps it would be different on yours, but it should be similar.  I navigated to "Settings," then went to the bottom of the list and opened "About Phone."  There I opened "Software Information" and tapped 7 times on "Build number."  This put the phone into Developer Mode.  I then went back to Settings and discovered that there was now a category at the bottom of the list of Settings called "Developer Options."  This is where I found the toggle for "Keep Mobile data turned on."  

 

I hope this might work for some of you who are having this MMS problem.  It took me a lot of sleuthing to figure this out.  Good luck!

 

 

Groupie

I re-downloaded the Messages app and phone started receiving mms....
Was amazed...problem could be Messages app got corrupted during update
Enthusiast

My phone is not rooted... so I was unable to uninstall/reinstall the default samsung messaging app.

Instead, I switched to the Google Messages app. Can send send mms on LTE network without issue now.

Looks like it is possibly a samsung issue.
Groupie

THANK YOU!!!!! This is ABSOLUTELY the only thing that's actually worked for me. I was losing my mind over how insane this stupid problem has been. It's a basic function of cellular tech, shouldn't be such a hassle. Whoever you are, post this somewhere everyone can see it cause I guarantee you there are 500 more people out there about to throw their phones across the room lol.