Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Highlighted
Accomplice

Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Hello!  I have researched this on the Boost website, and the internet in general, and now on this Boost Community.  Numerous times I have reset the network settings on the phone, done the SCRTN reset, updated Profile and PRL, and other things.  But still I have this problem.

 

I can no longer send or receive MMS messages (so texts including pictures, or texts to/from multiple other contacts) if my Wi-Fi is turned on. 

* For messages I try to send, I see the spinning circle that they are trying to send, but they eventually fail and won't send unless I turn off my Wi-Fi and try again.  Then it happens, although often slowly.

* For messages I receive, I get a text placeholder that tells me I have a message to download.  I have to turn off my Wi-Fi, click on the message, and wait for it to show on my phone.

 

Through trial and error I have discovered that if I set my phone to "CDMA" (3G) as opposed to CDMA/LTE, then it seems work  even if Wi-Fi is on, but is of course slow when using network data.

 

I have seen on other posts that the Android 9 update caused LTE issues on Samsung Galaxy phones and wonder if this is a related issue.

 

Is there a fix, so that I don't have to choose between constantly toggling Wi-Fi on and off OR restricting my phone to 3G data speeds?

 

Thanks,

JC

53 REPLIES 53
Highlighted
Enthusiast

I'm also running into the same problem and have tried everything. 


Those who are switching carriers, where are you thinking of going? I'm too impatient to wait on Boost to resolve this. 

Highlighted
Accomplice

I'm probably switch to cricket. They're cheap and use ATT towers. Or perhaps a WalMart plan.
Highlighted
Enthusiast

Im also thinking of straight talk from WalMart. Ive had them before and left because Boost had a cheaper plan. Now Straight Talk has an even better plan than Boost.
Highlighted
Enthusiast

Same problem here. Samsung S8. Tried all the "fixes", but so far nothing works. Only work around I've found is switching my phone into CDMA mode only. So yeah, it's 2020 and I'm stuck using 3G!! Been a loyal boost customer for 8+ years. But if Boost doesn't find a solution, I'll have to jump ship.
Highlighted
Agent

Hi! Thank you for bringing this up to our attention. We sincerely apologize for the difficulties you're experiencing. We'll do our best to help you today. Please send us a private message, so we can review the steps you have tried, and try something else directly from your account to see how it works out. Thank you. ~AmyM25

~AmyM25
Highlighted
Enthusiast

Hello, same issue here.  MMS messages are not sending/receiving on WiFi or 4G for past several days.  I can PM details, can you help to resolve this please?

Highlighted
Agent

Hello, BA22. Please send us a private message with your phone number and PIN.

Highlighted
Groupie

I have been having this exact same issue since July! Boost has been giving me the runaround and I have tried every code and even did a factory reset!! It still won't work right! They kept blaming Samsung until I took my phone there and had a diagnostics ran on it and was told it was BOOST's NETWORK!! When I called and told them they argued with me assuring it was not the case or my phone would not work at all!! There's a lot more to this issue but you get the point. I am drained and tried getting another service, long story short Boost would NOT unlock my phone because I haven't had it for a year yet!!! I asked them what difference does it make if I pay it off and they told me it's their policy!! I am beyond LIVID and ready to take matters to a more serious step!!

Highlighted
Enthusiast

I have been having the same problem for a couple of weeks., suddenly unable to receive or send MMS messages on two different Samsung Boost phones that I've been using without problems for a couple of years. 

 

I have found a solution that works on both my Galaxy J7 Perx phone and my Galaxy S8 phone.  Here's what worked for me, so that I can now receive MMS messges and ALSO keep my 4G LTE service (with the network mode set back to "automatic" instead of the slower "CDMA," which I had to use for the weeks before I figured this out).

 

The solution for both phones involved going into "Settings" and turning on "Developer Mode."  This opened up a  "Developer Options" category in the Android Settings, which allowed me to toggle on a switch called "Keep Mobile Data turned on - Keep Mobile data turned on at all times, even while WiFi is in use, to make it quicker to switch networks."  

 

Once I had toggled this switch "on," I went back to "Connections / Mobile Networks" and reset the network mode to "Automatic."  When the phone restarted, I once again had 4G LTE service and my MMS messages were working as they have for years.

 

This is how I turned on "Developer" Mode on each of my phones.  Perhaps it would be different on yours, but it should be similar.  I navigated to "Settings," then went to the bottom of the list and opened "About Phone."  There I opened "Software Information" and tapped 7 times on "Build number."  This put the phone into Developer Mode.  I then went back to Settings and discovered that there was now a category at the bottom of the list of Settings called "Developer Options."  This is where I found the toggle for "Keep Mobile data turned on."  

 

I hope this might work for some of you who are having this MMS problem.  It took me a lot of sleuthing to figure this out.  Good luck!

 

 

Highlighted
Groupie

I re-downloaded the Messages app and phone started receiving mms....
Was amazed...problem could be Messages app got corrupted during update