Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Highlighted
Accomplice

Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Hello!  I have researched this on the Boost website, and the internet in general, and now on this Boost Community.  Numerous times I have reset the network settings on the phone, done the SCRTN reset, updated Profile and PRL, and other things.  But still I have this problem.

 

I can no longer send or receive MMS messages (so texts including pictures, or texts to/from multiple other contacts) if my Wi-Fi is turned on. 

* For messages I try to send, I see the spinning circle that they are trying to send, but they eventually fail and won't send unless I turn off my Wi-Fi and try again.  Then it happens, although often slowly.

* For messages I receive, I get a text placeholder that tells me I have a message to download.  I have to turn off my Wi-Fi, click on the message, and wait for it to show on my phone.

 

Through trial and error I have discovered that if I set my phone to "CDMA" (3G) as opposed to CDMA/LTE, then it seems work  even if Wi-Fi is on, but is of course slow when using network data.

 

I have seen on other posts that the Android 9 update caused LTE issues on Samsung Galaxy phones and wonder if this is a related issue.

 

Is there a fix, so that I don't have to choose between constantly toggling Wi-Fi on and off OR restricting my phone to 3G data speeds?

 

Thanks,

JC

53 REPLIES 53
Highlighted
Accomplice

It has for years, that's not true. This is a recent issue.
Highlighted
Accomplice

That does not work and a insufficient solution. Please do your due diligence to either correct this issue or let us know why this is happening.
Highlighted
Accomplice

Thank you for bringing this issue to the forefront. It has been such a PAIN and Boost won't take ownership. I've had them for YEARS and never had this issue until now. It's the most frustrating thing. Nothing fixes it. Switching to another service is an awesome idea and I will plan to do the same!! Thank you 🙂
Highlighted
Agent

Hello, @jeanineb20. We're sorry to know that you're also experiencing this issue. Please send us a Private Message so we can take a look. 

 

To send a Private Message you can go to your profile and click on the icon with an envelope. Then you enter the username of the person you want to send a message to and the subject. Or you can go to the user profile by clicking on the username and click on "Send this user a Private Message".

Highlighted
Accomplice

I have called several times, even spoke to a supervisor in your office who couldn't help at all. Not sure if sending a private message will help any further. I've tried everything possible and Boost kept placing the blame on Samsung. My phone is new and I hadn't problems with it all year until August. I think it has something to do with TMobile integrating with Boost. It has been such a PAIN and Boost won't take ownership. I've had your service for YEARS and never had this issue until now. It's the most frustrating thing. Nothing fixes it and no one will seem to tell me why this is happening. 

Highlighted
Agent

Hi there jeanineb20. We definitely want to look into this. Please send us a private message with your phone number, pin code, and street address and we will verify. victor21

Highlighted
Accomplice

Ok, I will.

Highlighted
Accomplice

You're absolutely correct when you say this has never been the case. I have had Boost and this Samsung Galaxy 8 for years, and just last month is when this began. I have a feeling it's because they want to run up everyone's data usage by getting them to switch off wifi to send/receive messages. This is a BOOST ISSUE, not a Samsung issue, and they are spinning the narrative to make it look like MMS issues were always there. Time to get a better carrier, even though I've been happy with them for years before this. Sucks for me and sucks for them since they won't be making any more $ off me. I posted a big rant about how I've called 5 times this month and received a different answer for the problem every time - tower issues, Samsung problem, update problem, tower again, etc. They have no idea what to say because they aren't interested in fixing it, just lip service until you decide to hang up. This DISH merger is probably the end for Boost - it's certainly looking like the end for me, too.

Highlighted
Accomplice

Yes, I couldn't agree with you more! It's sad I just private messaged them and they had me do the same things I've been doing several times ##72786#. They said they don't have a solution right now. It's unfortunate to continue to lose valuable loyal customers over this, it's severe enough to make people walk away and I don't think they understand the repercussions. I too will be joining in on switching carriers, this is a major inconvenience that should have been fixed by now.
Highlighted
Enthusiast

so its October 19th today and same issue is going on, I have perfect 4g LTE all bars, perfect WIFI, I can send and receive phone calls, voicemail and texts just fine, but MMS still does not work I can not send or receive them, sending fails after several minutes of the hamster wheel spinning, and still get the "download message" banner when some one sends me a MMS. I went to a boost store today and they said it was a known issue, so their is still no fix, I tried the whole PRL, profile update and the ##72786# reset and still no resolve. the lady at the boost store said so far that she has been met with android users s9 and older with this issue. its completely ridiculous that this is still going on for over a month now from what I can tell, I didn't know it was happening that long because my phone started doing this last week I have an s8