Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Highlighted
Accomplice

Galaxy S8 - Can't send MMS messages with Wi-Fi turned on, unless I force the phone to CDMA/3G only.

Hello!  I have researched this on the Boost website, and the internet in general, and now on this Boost Community.  Numerous times I have reset the network settings on the phone, done the SCRTN reset, updated Profile and PRL, and other things.  But still I have this problem.

 

I can no longer send or receive MMS messages (so texts including pictures, or texts to/from multiple other contacts) if my Wi-Fi is turned on. 

* For messages I try to send, I see the spinning circle that they are trying to send, but they eventually fail and won't send unless I turn off my Wi-Fi and try again.  Then it happens, although often slowly.

* For messages I receive, I get a text placeholder that tells me I have a message to download.  I have to turn off my Wi-Fi, click on the message, and wait for it to show on my phone.

 

Through trial and error I have discovered that if I set my phone to "CDMA" (3G) as opposed to CDMA/LTE, then it seems work  even if Wi-Fi is on, but is of course slow when using network data.

 

I have seen on other posts that the Android 9 update caused LTE issues on Samsung Galaxy phones and wonder if this is a related issue.

 

Is there a fix, so that I don't have to choose between constantly toggling Wi-Fi on and off OR restricting my phone to 3G data speeds?

 

Thanks,

JC

53 REPLIES 53
Highlighted
Groupie

Hello- I am also going to start looking if it continues. It just stinks because I have to buy 2 new phones, sine my son is on my account. But I agree its not getting any better.  Should I try that ##SCRTN#? what will that do?

Highlighted
Accomplice

Yes by all means give it a try. It does not hurt anything. It will cause your phone to restart and it just finds the Boost network as though it were a new phone and then updates the background phone network stuff. But it will not remove any of your photos or files or anything else. The other thing that works for me is if I manually set the network mode to CDMA only which is just 3-g. If I do that the phone seems to work pretty well although obviously I'm not getting the LTE speed. But I just looked at prices for AT&T and Verizon and I'm still paying a lot less on Boost then I would be on them. So maybe I will just learn to live with 3-g speed for those infrequent times that I can't use Wi-Fi.
Highlighted

Hi there! Sorry for the delayed response. Support is available from 6 am - 10 pm CST Monday - Friday, and from 6 am - 9 pm CST on weekends. 

 

Sorry to hear that you are experiencing this. Could you please tell us if your Samsung S8 phone is showing the VoLTE option? You should be able to see it on Settings> Connections> Mobile networks.

Highlighted
Accomplice

Thanks for the reply.

I do NOT see the word "VoLTE" anywhere in the Mobile Network menu or in any submenus there.

Highlighted

Thank you. Your phone uses the mobile data to send MMS messages. Your phone should automatically use the mobile data to send the MMS even when connected to WiFi. We would like to access your account to verify the network settings. Please send us a private message to assist you. To send a Private Message, click my username or picture, then click "send this user a private message".

Highlighted
Accomplice

Just for anyone who reads this, I did PM with the Social Care reps.  While I am appreciative of their intentions, the suggested solution was to do the ##72786# again.

 

So I did, but that still has not fixed the problem or changed anything that I can see.

 

So for now I have switched my phone to "CDMA" network mode, which seems to make the phone function correctly, but restricts it to only the 3G network.   Until a better fix is offered.

Highlighted
Accomplice

Yet you can send MMS to others with WiFi on if they're in the boost network.
Highlighted
Agent

Hi. Thanks for contact us. Some devices are manufactured to receive and send Multimedia Messages (MMS) while connected directly to the carrier's network. If you have any other question or concern, feel free to reply.

Highlighted
Accomplice

FWIW I have switched to Cricket Wireless with the same phone and am very pleased so far. Cricket is actually slightly cheaper with a dual line discount than Boost but I do not get the free 10 GB of hotspot. So it's a trade-off. But I can send MMS messages with Wi-Fi on again!
Highlighted
Enthusiast

****** Since when?!? Never had any problems till a couple months ago