Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html
Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html

Data Roaming option greyed out. Can't send/receive MMS messages

Groupie

Data Roaming option greyed out. Can't send/receive MMS messages

I recently switched from the Samsung Galaxy J3 Emerge to the J3 Achieve. With the Achieve I cannot send or receive MMS messages at my work office because it says I need to turn Data Roaming on. However, I cannot turn it on because it is greyed out.

 

The exact message I get is "You have lost data connectivity because you left your home network with data roaming turned off". My office is outside of my home area. I have tried turning it on before I leave home but it is always greyed out. I have no ability to turn it on or off.

 

I have the same service plan and work at the same place as with the J3 Emerge and I did not have this problem before.

 

Can anyone help?

 

THANKS!!

12 REPLIES 12
Highlighted
Agent

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Hi there kwblack. Sorry about the issue there. Let us look into this. Can you please send us a Private Message we your phone and pin number so we can better assist you? 

Highlighted
Groupie

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Sending you a private message now. Thank you!
Highlighted
Newbie

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Hello Alex my phone has had the same issues above for about 2 weeks now. Is there anything I can do to fix it?
Highlighted
Accomplice

Re: Data Roaming option greyed out. Can't send/receive MMS messages

I have the same issue and have TRIED to turn roaming notifications off but even that is grayed out/won't allow me to turn it off so I don't have to constantly get these annoying notifications!! It really is a pain to always get a notification whenev my phone's signal fades in & out (which it does so alllll the time bcuz I live in an area where cell service is spotty).

The notification on-screen and off is extremely disruptive bcuz I often use my device to edit photos or my logos for my business and when the visual notification occurs, it moves my whole screen down which causes me to make huge mistakes in my editing. The audible notification goes on all throughout the night, awakening me or if I'm listening to music at a high volume, nothing more annoying than a disruptive roaming notification to ruin the mood lol

Everyone else has the capability to turn off notifications so why doesn't Boost Mobile allow us to turn ours off?
please help!
Highlighted
Accomplice

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Hi, 

In order to use data and picture/video messaging (MMS) with the Roam Mobility network, you will need to configure the APN (Access Point Name) and MMS settings on your device. For instructions on how to set your APN click here

 

Highlighted
Enthusiast

Re: Data Roaming option greyed out. Can't send/receive MMS messages

I am having the same issue.

Highlighted

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Don’t you fret, knock418! We’ve got you covered. Can you please send me a private message with the address where this occurs, your phone number and PIN? 

 

To send a private message just click on the picture of any Boost Mobile agent and, in the next screen, click "send this user a private message". 

Highlighted
Groupie

Re: Data Roaming option greyed out. Can't send/receive MMS messages

I have the LG X Charge. My work doesn't have strong connection. It says that I have to turn on data roaming, but I can't because it is greyed out. How can I fix it?
Highlighted
Agent

Re: Data Roaming option greyed out. Can't send/receive MMS messages

Hi there, linn. Thanks for contacting us. 

 

We'd like to have a look. Please, send us a private message with your address to check the coverage.