Can't send/receive MMS over WiFi (Galaxy S8+)

Highlighted
Accomplice

Can't send/receive MMS over WiFi (Galaxy S8+)

I have a Galaxy S8+. About a month ago I lost the ability to send and receive MMS when WiFi is turned on. I can still send/receive MMS when WIFi is disabled. I've restarted my phone, confirmed that mobile data is on, have switch to cellular data when Wi-Fi is unstable enabled. I also tried resetting my network settings and did a full factory reset for my phone. None of these efforts resolved my issue. Please help thanks
34 REPLIES 34
Highlighted
Agent

Hi there, LGStylo2. We can guarantee that MMS will work while you are using the mobile data that we provide. Usage while connected to WiFi also depends on the phone and software updates. 

Highlighted
Accomplice

Howdy! I just posted about what I think is the identical issue, also on an S8.

 

I have found if I change the phone network from "Automatic" or "CDMA/LTE" to "CDMA" (which is 3G) then it works but slowly.  And obviously since I am paying for 4G, I want to be able to use my LTE without constantly toggling the Wi-Fi on and off.

 

Sorry I don't have a solution, but wanted to let you and Boost know that it is not just you.  I am having the same issue, and it also started maybe a month ago but took me a little time to really recognize and diagnose.

 

-JC

Highlighted
Accomplice

Well my mind is blown. Read the responses on my thread which are essentially "Yep it's broken. We're not fixing it. Deal with it."

I've been a happy Boost customer until this point and even recommended friends to use Boost. But if this is not resolved I be switching carriers and warning others away.

https://community.boostmobile.com/t5/Samsung-Phones-Devices/Galaxy-S8-Can-t-send-MMS-messages-with-W...
Highlighted
Enthusiast

so its October 19th today and same issue is going on, I have perfect 4g LTE all bars, perfect WIFI, I can send and receive phone calls, voicemail and texts just fine, but MMS still does not work I can not send or receive them, sending fails after several minutes of the hamster wheel spinning, and still get the "download message" banner when some one sends me a MMS. I went to a boost store today and they said it was a known issue, so their is still no fix, I tried the whole PRL, profile update and the ##72786# reset and still no resolve. the lady at the boost store said so far that she has been met with android users s9 and older with this issue. its completely ridiculous that this is still going on for over a month now from what I can tell, I didn't know it was happening that long because my phone started doing this last week I have an s8

Highlighted
Agent

Sorry to hear that, jerry_H. Can you send us a private message so we can look into it?

Highlighted
Enthusiast

.
Highlighted
Enthusiast

has their been any rectification on this?
Highlighted
Enthusiast

I am having this same issue, for about 2 months now! Very annoying! Please let me know if you figure this out.

Highlighted
Accomplice

Switching to 3G fixes the problem. Unfortunately limits you to 3G.