My data pack add ons not registering, can't use.

Highlighted
Newbie

My data pack add ons not registering, can't use.

Ran out of monthly data on my HotSpot wifi, so I bought a 1GB add on for $5 and a 2GB one for $10. Although they show up on on my account good til 10/3, they haven't been added to my main total of 10GB, it still states 10240MB of 10240MB used. Have called customer service several times and just got the run around and excuses for nearly an hour each time. Last month the data packs were added to my data counter (10240MB of 13312MB) and were available immediately after purchase. I've reset the HotSpot several times and still getting redirected to Boost Account Website like I'm still out of data six hours later! Please help, thanks.
1 REPLY 1
Newbie

Re: My data pack add ons not registering, can't use.

Well after two more calls to customer service and being put on perm-a-hold for 30min, I called back to ask for a supervisor off the rip. She told me the monthly standalone HotSpot plan I had, $50 / 10GB, didn't have the data pack add on options. Although, I had purchased and successfully used up two data add ons the previous month. Anyways, the supervisor was able to take the unusable data packs off my plan and credit my account balance for the $15 I paid. What I assume happened was, although last month's data add ons had been used up they had not yet expired, and remained on my plan for the new month. When I couldn't add the packs on myself I called customer service to have them do it. I recall she had trouble at first but after some waiting she said I was good to go. This is when the trouble started... funny thing is after all that, when I went to check my balance for the refund, I noticed the data packs were now available for purchase. For chitz and giggles I bought the $5 data add on; low and behold, I'm finally back online.