Switching from LTE to 3G constantly and apps say "No Connection"

Groupie

Switching from LTE to 3G constantly and apps say "No Connection"

For the past 3 months my service has went to garbage. Phone constantly switched from LTE to 3G and then half of the time, no matter what it is displaying, my apps or web browser will say that I have no connection. I have let it go and let it go, but today has set me off. I can't even use my hotspot because the piece of crap network will not hold a steady connection for longer than 2-3 minutes. Once again, the phone displays LTE, then 3G, LTE, 3G, all consistently, but there is NO ACTUAL internet and my phone can be sitting in any one spot when this occurs, not even in my hand. Of course, they just got their $50 from me today, so ONCE AGAIN, I've wasted my money for another month of sub-par service. Anyone else have this problem?
3 REPLIES 3
Accomplice

Re: Switching from LTE to 3G constantly and apps say "No Connection"

My phone stays at nearly full LTE and yet I cannot use any applications or my hotspot. $60 a month for my data to not work is insane. This happens with another persons phone in my household. Our data slows down to a crawl even though our service is good. We are always told no outages so we cannot be compensated, I think it's time we are compensated till the issue is fixed.

Groupie

Re: Switching from LTE to 3G constantly and apps say "No Connection"

My service has gotten worse over the past 3 months and i DO believe a credit is due. I've had boost for about 9 or 10 months now and it's getting ridiculous. I'm goung to start keeping track of the time I do not have service every day.

Re: Switching from LTE to 3G constantly and apps say "No Connection"

Interesting. How about we take a closer look at this? Can you please send me a private message with your current address location, phone number and PIN number? 

 

To send a private message just click on the picture of any Boost Mobile agent and, in the next screen, click "send this user a private message".