Horrible service since switching to Enhanced Network

Highlighted
Accomplice

Horrible service since switching to Enhanced Network

I just switched to the new enhanced network plan about 4 days ago and got the new SIM card and had it activated. My data is very slow and is constantly showing No Service! When I look at the coverage for my area it shows as “Best” coverage but it sure is the “Worst!” Please help or I gotta go somewhere else! This is ridiculous to pay more and getting less!!
15 REPLIES 15
Highlighted
Agent

So sorry to hear that, kimpossible8687. Let's do some investigating. Please, send us the nearest cross streets and zip code where this occurs to check the network performance.

Highlighted
Accomplice

29414 and I’m at Magwood Drive near Hwy 61
Highlighted
Agent

Thank you. At the moment, there are no outages reported. Please, make sure that the Wi-Fi is turned off and Mobile Data is turned on. After that, turn off the phone and remove the SIM card for two minutes. Once it's back on, try to update the Profile and the PRL. Go to Settings > System Updates. Keep us updated with the results.

Highlighted
Accomplice

I have an iPhone 6 and cannot do that
Highlighted
Accomplice

But I did do a network update #8733283# and its saying "Error performing request unknown error", which is something new because it's always worked before.
Highlighted
Agent

Understood. We'd need to review your account. Please send us a private message with the account phone number, pin code, IMEI, and SIM card number.

Highlighted
Accomplice

 
Highlighted
Accomplice

How do I private message you?
Highlighted
Agent

To send us a private message, please click on the picture of the agent and then select 'Send this user a private message'.