Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html
Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html

Domestic roaming

Highlighted
Groupie

Domestic roaming

I have a Samsung Galaxy S9 and I can not enable domestic roaming. All the options are greyed out. I've never had an issue where I live but I've been working out of town in the mountains and i completely lose signal. I can't make any phone calls in a lot of areas. So I'd like to enable roaming but can't. I've tried resetting the prl with the ##72786# code and that didn't work either. Any help would be appreciated because this is frustrating
See more topics labeled with:
4 REPLIES 4
Highlighted

Re: Domestic roaming

Hey there, Unspeaking! We’d be happy to help, Unspeaking! Please follow these steps:

1. Slide your finger down the display starting from the top edge of your mobile phone.
2. Press the settings icon.
3. Press connections.
4. Press Mobile Networks.
5. Press Data roaming to activate or deactivate the function.
6. Pres the home icon to end the session and return to the Home screen.

Highlighted
Groupie

Re: Domestic roaming

It is greyed out! Im not trying to be rude but i thought i made this clear in my original message. You can not turn any of the options on or off!
Highlighted
Groupie

Re: Domestic roaming

Highlighted
Agent

Re: Domestic roaming

We understand your frustration, @Unspeaking, and we apologize for the inconvenience. To research further, can you please send us a private message with your phone number, PIN, and address where you're currently located?

 

To send a private message just click on the picture of any Boost Mobile agent and, in the next screen, click "send this user a private message".