Moto g6 play MMS message

Highlighted
Groupie

Moto g6 play MMS message

Sometimes can't send or receive MMS (picture/video texts). When receiving a MMS text, I'll have a blue symbol with a spinning circle that will just sit there and never download. If I restart my phone, it will turn into a blue circle with a white arrow saying download, but when clicked, it will either take 5-10 minutes to download, or just spin and spin...
Today I was told that I was being sent picture messages but I didn't even get a notification that anything happened. No text alert, spinning symbols, or anything. This happened on my old phone (Samsung Galaxy prevail) through this same Boost service, and now it's the same issue on my Moto g6 play. I am connected to very good wifi with full connection when having these issues. The phone sending me messages is an iPhone.

Another note is when I'm NOT on wifi, I never get 4G connection despite my plan being 4G unlimited. It says 3G or LTE, and runs verrrrry slowly, if at all. Especially when inside a house. I do double check my mobile data is on, but even if I do turn it back on (when I never manually turned it off myself) I still get this second issue.

For both of these issues I usually only have 1-3 out of 5 bars for connectivity. I live in town, so I don't get why I have such bad connectivity/MMS issues. 😞
2 REPLIES 2
Highlighted
Agent

Re: Moto g6 play MMS message

Hi there! If the mobile data is being turned off by itself, your phone has a data saving option turned on. We recommend turning it off, as it will affect the way that you experience our services in a negative way. If the data saving option is turned off, but the issue persists; please send us a private message so we may take a closer look.

 

You can send a private message by clicking on my name, then selecting the message option from the profile page. 

Highlighted
Groupie

Re: Moto g6 play MMS message

Okay, I privately messaged you