LG Stylo 2 Can't Activate Domestic Roaming

Highlighted
Accomplice

LG Stylo 2 Can't Activate Domestic Roaming

Hi,

 

I have an LG Stylo 2 thru Boost unlimited plan w/todo mexico plus.  When activating roaming on my phone, I can activate international roaming but am unable to toggle the domestic roaming on (domestic talk and date roaming toggles are greyed out).   Boost's website says that the LG Stylo 2 is enabled for both domestic and international roaming.  What do I have to do to enable domestic roaming? Thanks

6 REPLIES 6
Highlighted
Agent

Hi there!

 

Have you checked to see if the Roaming Mode is on Automatic? Investigating on the LG Support site, we found the following instructions on how to set up your roaming service.

 

  1. From the home screen, swipe down the Status bar.

  2. Tap the Settings icon.

  3. From the Networks tab, scroll to and tap Roaming.

  4. Tap Roaming mode.

  5. Tap Automatic to enable roaming.

    Tap Home only to disable roaming.

  6. If enabling Roaming, ensure Domestic voice roaming is turned ON.

    Tap the Domestic data roaming switch to ON to enable data roaming access.

    Note: If a warning message prompts when enabling Domestic voice and data roaming, review the message and tap the preferred option.

  7. The roaming settings are now changed.

We hope this helps!

 

EdwinRG.

Highlighted
Accomplice

Thanks for your reply.  Roaming and international roaming are enabled.  It just won't allow me to toggle the domestic roaming functions to the "on" position.  There is no "automatic" or "home only" setting for roaming on the Stylo 2.  There is a network setting (currently set to "automatic" as opposed to LTE/CDMA, CDMA, or GSM).  If you have any other suggestions, please let me know.  Thanks

Highlighted
Agent

Hey there, @LGStylo2! Do you confirm that on the LG Stylo 2 from Boost Mobile, you could not see the steps below with the option to enable Roaming? 

 

1. Tap > Tools > Settings > Networks tab > Roaming.
2. Tap Roaming mode to change the CDMA roaming mode.

Home only to access only the home area mobile network, which is the Nationwide Boost Mobile Network. This option also prevents roaming on other networks.

Automatic to seek service off the Nationwide Boost Mobile Network. When Boost service is unavailable, the phone searches for an alternate system.


3. Tap each Domestic roaming option and International roaming option to place a check mark and connect to voice and data service while roaming.

Highlighted
Accomplice

Here are the options on my "networks" tab under settings.  

 

1) Click "More" to access roaming and mobille network settings

2)Click "Mobile Networks"

3) This displays settings for "Roaming" and "Network Mode"

 

"Network Mode" is set to "automatic."  There is no "home only" option.  Only automatic, LTE/CDMA, CDMA, and GSM

 

"Roaming" displays five settings

1) Use Roaming (currently toggled on)

2) Domestic voice and text roaming (unable to adjust--greyed out and unable to change from "off" position

3) Domestic data roaming (unable to adjust---greyed out and unable to change from "off" position

4) International voice and text (toggled "on")

5) International Date (toggled "on")

 

I have not found any other way to access roaming settings or any option that says "home only."  So my roaming says it's enabled, and my international roaming is enabled, but I can't turn on domestic roaming.  I found a thread for another user ask about this in the community a while back as well whose issue was not solved.  I need to know if there is a fix for this or not.  Thanks

Thanks,

 

Ryan 

 

Highlighted
Accomplice

To access Roaming settings I have to go to "More" under the "Network" settings tab.   Then I go to "Mobile Networks."  Under this, there is a tab for "Mobile Networks" set to "automatic" and a tab for Roaming which has roaming enable and international roaming enabled but will not allow me to adjust domestic roaming.  Don't see a "home only" setting anywhere.  Here's another user who had the same issue with the same phone without a solution (below).  I just need to know if there's a fix for this or not.  Thanks

 

https://community.boostmobile.com/t5/LG-Phones-Devices/LG-Stylo-2-Data-roaming/td-p/16044

Highlighted
Agent

Hi there, LGStylo2. Thank you very much  for contacting us. 


We're sorry for the inconvenience with the roaming. We'd like to have a look at the account. Please, send us a private message your with phone number and PIN to have a look at your account.