Internet/data service not working well

Accomplice

Internet/data service not working well

I used to get good to very good 4G LTE data service in 60076 until about 2+ weeks ago. Now, I mostly don't get any

data connection (Internet browser will say I am offline; phone applications don't work). I might get momentary 3G and

maybe 4G-LTE data service but it doesn't last. For all practical purposes, I do not have data service here. Sometimes, I see

zero-1 bars antenna strength so I assume there are times I have no voice either. I've gone through the phone reset; profile

updates, PRL updates, etc. with Support and none of these fix anything. I have had the phone's data service work well

in other zip codes farther away. So, what's going on here? I don't think it's the phone. And since it's been 2+ weeks, any

local malfunctioning  tower equipment ought to have been detected and fixed by now. I use only about 1.5 - 2.0 GB data

monthly within a Growing Data plan at 3.5-GB (It should be more; that's another problem that doesn't seem to get fixed

over the past year). Can someone in Boost Mobile help me out here?

6 REPLIES 6
Enthusiast

Re: Internet/data service not working well

What IS going on? I'm dealing with the EXACT same issues in 47804. Mine also goes offline, for a few seconds or even a minute or two. I have done updates too. My data service works better in zip codes farther away too. It's definitely not the phone. Not getting my money's worth of service that's for sure. PLEASE HELP BOOST!
Agent

Re: Internet/data service not working well

Hello! We’re sorry to know that you are having this issue. We'll be happy to help you. Please send us a private message with your cross-street address, assist you with this.

Re: Internet/data service not working well

I am dealing with the exact same problems, although its been going on for a month. I am about to go through different carrier, its ridiculous!

Re: Internet/data service not working well

I am dealing with the exact same problems, although its been going on for a month. I am about to go through different carrier, its ridiculous!
Groupie

Re: Internet/data service not working well

I'm dealing with the very same issue. Problems became more severe when I call support. I told them I get better connectivity with a hotspot i bought and made a seperate account. Pre-paid data cards. Pre-paid service. The hotspot worked fine before the call. Once I gave the info that it is on the same tower as phone and same 4g that I'm trying to use my hotspot tethering on phone. Now It doesn't get the same bandwidth as before. My phone gets no data. cannot use internet apps or hotspot tethering connectivity. This is ridiculous. They know the issue is on their end or that Sprint has limited my phone and hotspot macs. Advertising something they will not allow or help me receive. I made a second call to support after the hotspot stopped getting bandwidth. Offered to send me another device. LOL. Nothing wrong with it before. I made the mistake of tell them that I tried using hotspot on the family data plan from my girlfriends phone. It worked as it was supposed to untill I got off the phone. Going to another provider after service cycle ends. Ripping me off going on 3 months. 

Agent

Re: Internet/data service not working well

Yikes! Really sorry you feel that way, @ugetdeltwit. Looks like we’ll need to do some investigating. Can you private message us your phone number so that we can verify your account first? Thanks!