Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html
Boost Mobile Community is currently read-only. Please use the My Boost app or BoostMobile.com to manage your account. If you need assistance, please visit https://www.boostmobile.com/support/contact-us.html

Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Go to solution
Highlighted
Accomplice

Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Livid right now as I type this. I am brand new to Boost as of yesterday. I spent all of yesterday going back and forth with Boost because my phone was not getting any service despite me living between two of their towers. After being put in touch with a supervisor, they cancelled my account and recreated it with a new number, and I got service this morning. 

Now it says my phone has been disconnected due to non-payment, I can't log into my Boost account w/ my number and pin because it says it was a demo account. I can't call Boost because I now don't have a working phone, so I tried contacting them on Facebook and Twitter. I tried to have them call me, but they can't call the phones they've disconnected apparently. I'm up in flames right now. I can't call or text to verify my info, they can't reach me, and so they told me to come here... But how is this any different?! It's still not a secure source to verify through. I feel like I've just jumped down a rabbit hole... Someone please friggin' help me!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Can you please send the message one more time. We have tried to locate your message with no success.

View solution in original post

16 REPLIES 16
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Hi vlawson18! We are sorry about the trouble. Please send us  Private Message with your phone number and PIN so we can further investigate.

Highlighted
Accomplice

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

How do I PM you? Is this how?
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Click on my user name and you will see the option to send a Private Message.

Accomplice

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Okay sent
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Thanks! We'll assist you through Private Message.

Highlighted
Accomplice

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Did you receive the messages?
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Can you please send the message one more time. We have tried to locate your message with no success.

View solution in original post

Highlighted
Accomplice

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

SHould I title it the same as this post?
Highlighted
Agent

Re: Activated Boost yesterday, had no service until this morning only for it to be disconnected?!

Than would be very helpful.