hlf_pdx's profile

Tue, Feb 4, 2020 1:00 PM

New Samsung Galaxy A20 not sending/receiving MMS

Just switched phones from an LG to this new Samsung Galaxy A20, got all my info transferred over from the old phone more or less without a hitch, as well as my old SD card, etc. It looks like the phone activated on my Boost Mobile account just fine.

 

In the top left it says "Sprint" for the network instead of "Boost" though, and I'm not sure why.

 

My main concern though is that, while I've gotten some text messages just fine, sending or receiving MMS picture or video messages is constantly failing. I haven't been able to get a single MMS message to send, and my boyfriend tried to send me a video message (something we do daily) that won't download at all.

 

I've rebooted the phone, checked any settings I can find for the messaging app... just no idea why text messages are coming and going fine, but no MMS. Anyone have any thoughts? And is it normal to say Sprint instead of Boost for the network?

Responses

Boost Care

 • 

3.3K Messages

1 y ago

Hi there, hlf_pdx! Let's do some investigating. Did you swap the SIM cards?

Boost Care

 • 

3.3K Messages

1 y ago

Understood. Please follow these steps on your phone: 
1- Select Settings.
2- Scroll to then select System Update
3- Select Update Profile. May also appear as Update Data Profile.
4- Update Profile - The network is preparing your services. Please wait displays 
5- Power cycle your phone.

Boost Care

 • 

3.3K Messages

1 y ago

Sounds good! If we can be of assistance, please do not hesitate to contact us. 

3 Messages

1 y ago

That totally fixed it! Thank you x1,000,000!

3 Messages

1 y ago

No, I didn't. I thought I would have to, but it never seemed to need me to, and just started getting texts.