LGStylo2's profile
Accomplice

Accomplice

 • 

8 Messages

Mon, Aug 31, 2020 10:00 PM

Can't send/receive MMS over WiFi (Galaxy S8+)

I have a Galaxy S8+. About a month ago I lost the ability to send and receive MMS when WiFi is turned on. I can still send/receive MMS when WIFi is disabled. I've restarted my phone, confirmed that mobile data is on, have switch to cellular data when Wi-Fi is unstable enabled. I also tried resetting my network settings and did a full factory reset for my phone. None of these efforts resolved my issue. Please help thanks

Responses

Fonsy82

Boost Care

 • 

3K Messages

 • 

1.1K Points

6 months ago

Hi there, LGStylo2. We can guarantee that MMS will work while you are using the mobile data that we provide. Usage while connected to WiFi also depends on the phone and software updates. 

Accomplice

 • 

22 Messages

6 months ago

Howdy! I just posted about what I think is the identical issue, also on an S8.

 

I have found if I change the phone network from "Automatic" or "CDMA/LTE" to "CDMA" (which is 3G) then it works but slowly.  And obviously since I am paying for 4G, I want to be able to use my LTE without constantly toggling the Wi-Fi on and off.

 

Sorry I don't have a solution, but wanted to let you and Boost know that it is not just you.  I am having the same issue, and it also started maybe a month ago but took me a little time to really recognize and diagnose.

 

-JC

Accomplice

 • 

22 Messages

6 months ago

Well my mind is blown. Read the responses on my thread which are essentially "Yep it's broken. We're not fixing it. Deal with it."

I've been a happy Boost customer until this point and even recommended friends to use Boost. But if this is not resolved I be switching carriers and warning others away.

https://community.boostmobile.com/t5/Samsung-Phones-Devices/Galaxy-S8-Can-t-send-MMS-messages-with-Wi-Fi-turned-on-unless-I/m-p/149433#M10735

Enthusiast

 • 

6 Messages

4 months ago

has their been any rectification on this?

Enthusiast

 • 

6 Messages

4 months ago

.
melissac

Boost Care

 • 

2.2K Messages

4 months ago

Sorry to hear that, jerry_H. Can you send us a private message so we can look into it?

Enthusiast

 • 

6 Messages

4 months ago

so its October 19th today and same issue is going on, I have perfect 4g LTE all bars, perfect WIFI, I can send and receive phone calls, voicemail and texts just fine, but MMS still does not work I can not send or receive them, sending fails after several minutes of the hamster wheel spinning, and still get the "download message" banner when some one sends me a MMS. I went to a boost store today and they said it was a known issue, so their is still no fix, I tried the whole PRL, profile update and the ##72786# reset and still no resolve. the lady at the boost store said so far that she has been met with android users s9 and older with this issue. its completely ridiculous that this is still going on for over a month now from what I can tell, I didn't know it was happening that long because my phone started doing this last week I have an s8

Enthusiast

 • 

3 Messages

4 months ago

I am having this same issue, for about 2 months now! Very annoying! Please let me know if you figure this out.

Accomplice

 • 

8 Messages

4 months ago

Switching to 3G fixes the problem. Unfortunately limits you to 3G.

Enthusiast

 • 

3 Messages

4 months ago

I myself have wondered if the merger has something to do with it. Not sure how I feel with TMobile running things. IDK. It seems to only be the Samsung's though and the older ones to boot. I don't know who's really to blame. But I've been with Boost for 10 years and really don't want to have to pay more by switching. Boost should give us some kind of incentive to be able to swap our phones because of this!

Accomplice

 • 

31 Messages

4 months ago

I have had this issue for 4 months where i randomly get my mms messages on my samsung galaxy s8 and have spoken to boost for a record over 5 hours. They still haven't figured out a fix for this. Their fixes like ##72786# might work for a bit then returns. Switching the wifi off also worked for a bit then returns. I went to 2 different stores and they had no clue and said that it's the phone and I should buy another. They keep blaming samsung and samsung says it's Boost. So here's what i've understood is the problem:  Boost sold out to Tmobile. So we are all on Tmobile now. Technical and legal battles having to do with MMS messaging is going on now with the acquiring of Boost to Tmobile is what's happening. Nobody has a FIX. I am so tired of this. Next time my payment comes up I'm switching. If by any chance there is a fix please contact me at . I have been a loyal Boost customer for 8 years and this is unacceptable.

Groupie

 • 

1 Message

4 months ago

I am having the exact problem. It started 2 days ago. I can send and receive text messages but no MMS, Same hamster wheel when sending and "download Message when receiving MMS. No answers yet??

Accomplice

 • 

31 Messages

4 months ago

None. I just keep getting the we're fixing it on the towers. It could take anywhere from 24 to 72 hours. I got this excuse over 3 months ago. I get my mms's after 24 hours after being sent. This is rediculous. 8 years with boost and then this happens. I may be jumping ship.

 

Enthusiast

 • 

5 Messages

4 months ago

Same issue here.  Had trouble with calls 2 months ago, fixed with ##72786# - but have had to use that reset code a few times.  Now MMS does not work at all - wifi or no wifi, until I set to CDMA only.  Everything had been fine until the update.  Now service is crap.  On top of that there is no Boost store on my island since they sold it off, so no where I can go to get it worked on in person.  Cricket wireless is looking better and better...

Enthusiast

 • 

5 Messages

4 months ago

Hello,

 

Generally doesn't give an error, it just spins the circle and doesn't send or receive.  When there is an error it is service not available.  Full LTE data.  Doesn't change with Wifi on or off.  I will remove and reinsert the SIM card but since that has been done before I think we both know it will not do anything...