julhawes's profile

Tue, Oct 27, 2020 11:00 AM

Galaxy S8 can not send/receive MMS or use mobile data

For nearly a week I have not been able to use my mobile data or send/receive MMS. I have tried resetting the phone, clearing caches, using the ##72786# reset, and resetting the network. Nothing is working and I am missing important messages from my employees and vendors. My account is completely up to date so there should be no reason I cannot use my mobile data. Ever since the merger I have had issues with my phone and service.


2 Messages

4 m ago

e answer is they upgraded their network and the Galaxy S8 is no longer supported. Their corporate-level support sucks and you will run in circles. I went to the local Boost store and got the facts. They wanted me to upgrade to S10 and offered a "deal" where I spend $900 I don't want to spend interest free over 3 years. I'm finding a new vendor.

11 Messages

4 m ago

Wow.  I hope it isn't that S8 is no longer supported. Sounds crazy.  Hopefully, I will eventually hear something meaningful back, even if it is they won't support S8s, from their support group. Not holding my breath, 8 days and counting...

11 Messages

4 m ago

Still working with Boost support.

- Initial tech support unable to do anything, as I've tried all things mentioned here in this thread (settings>general management>Reset>Reset Network Settings., ##72786#, reset provisioning etc.).

- They connected me to Samsung support, which had me do a few things (reset network, safe mode, etc.), and they determined there is nothing wrong with my phone and it is something with the Boost network.

- A few more days went by and Boost texted me, stating they found an issue with THEIR network, and they believe they have cleared it, and wanted me turn off/on my phone and to try again.  No luck, still not working.  BUT, at least they confirmed it is an issue with their network causing the problem.

- Called them again, and let them know this didn't work for me.  They escalated again to their next level support to investigate further.


Waiting to hear back from them again with a possible solution. At least they finally admitted that it is THEIR network that has a problem. Crossing fingers an actual fix will be coming soon.

11 Messages

4 m ago

I didn't hear anything back, so called them.  They stated it was fixed a few days ago, and to try again.  I rebooted my phone and I was now able to send MMS via text, but NOT receive.  I still needed to turn wifi off to download/receive MMS.


I called them back and they transferred me to their Boost IT support team.  Long story short, they're network group relayed to their IT group they need me to do a factory reset and try again.  This is an odd (stalling) request, since my phone and my wife's (S8 too) are doing exactly the same thing, as well as both now can send with wifi on. I explained this to them, but they're unwilling to do anything until I factory reset (and they do not have a plan for what is next).


I'm not into the idea of factory resetting (a hassle to reload everything), nor do I believe this will solve THEIR network issue. 


So, something was changed in their network as we can now send MMS with WiFi on.  So, you may want to try too. I'm going to wait another week and see if maybe receiving clears up. If not, and time permits, and I want to go through the hassle, I'll think about a factory reset, since they're unwilling to do anything further until then.

62 Messages

3 m ago

still ongoing.  I still CANNOT send MMS with wifi on. I either have to force it to 3 G or turn off WIFI. Not factory resetting phone, not buying a new phone as transferring all the info is PIA.

62 Messages

3 m ago

Their private messages don't do squat. They will tell you to ##72786# and/or factory reset phone that also does nothing but lose your customizations. Been n this predicament since Aug 2020. 


13 Messages

@u0999 Yep, 6 months I've had the issue, they refuse to do anything so I'm done with boost.  Going for AT&T this weekend. 

10 Messages

Yuppp! I'm done too.  We are paying for services that are not being delivered. No thanks. Not waiting around another 6 months!

4 Messages

2 m ago

Here is a workaround posted by another user:


Settings>about phone>software info>build infoxxxx (long press then select several times to activate developer mode)

Settings>developer options>enable - "mobile data always active" 

4 Messages

13 d ago

Activate Developer options (Settings > About phone > Software Information > tap Build Number 8 times). then back out to Settings > Developer options (at the bottom), scroll down to and enable "Mobile data always active".