LGStylo2's profile

Mon, Aug 31, 2020 10:00 PM

Can't send/receive MMS over WiFi (Galaxy S8+)

I have a Galaxy S8+. About a month ago I lost the ability to send and receive MMS when WiFi is turned on. I can still send/receive MMS when WIFi is disabled. I've restarted my phone, confirmed that mobile data is on, have switch to cellular data when Wi-Fi is unstable enabled. I also tried resetting my network settings and did a full factory reset for my phone. None of these efforts resolved my issue. Please help thanks

Responses

10 Messages

6 m ago

Thanks. I'll give it a try later on. I'm in AZ. At least until last weekend I still had to do the network switcharoo to CDMA for it to work. Others mentioned to just turn off WiFi and it worked for them but not for me, I tried.

10 Messages

6 m ago

Nah, I tried and it is still not working for me. I even turned WiFi off after the reset and tried to send a MMS. It didn't work. I guess I have to wait a little bit longer maybe?

10 Messages

6 m ago

Update: I had a provider Internet/WiFi outage last Saturday. While the WiFi/Internet service was out my phone was starting to send or receive MMS without the need to switch/reboot the network to CDMA as I have done till then. So, now, when sending/receiving MMS I just have to turn off WiFi. Yay. One milestone at a time.

10 Messages

6 m ago

Sorry, nope.

Update: I had a provider Internet/WiFi outage last Saturday. While the WiFi/Internet service was out my phone was starting to send or receive MMS without the need to switch/reboot the network to CDMA as I have done till then. So, now, when sending/receiving MMS I just have to turn off WiFi. Yay. One milestone at a time.

4 Messages

4 m ago

It's simply a technique to get you to buy a new phone. Software update not compatible with older phones. At least they could be honest about it. 

4 Messages

4 m ago

Problem started Sept 2020 & persists to this day

2 Messages

2 m ago

i believe i have resolved this on my S8+ by activating Developer options (Settings > About phone > Software Information > tap Build number 8x). then i went back to Settings > Developer options (at the bottom), scrolled down & enabled "Mobile data always active".

this may drain your battery faster & i would suggest that you DON'T TOUCH ANYTHING ELSE in Developer options unless you know exactly what it does.

good luck! 👍

4 Messages

@neyel8r - this work-around works for me! Battery life isn't an issue so much because my data is on pretty much 100% of the time anyway.

I've been so annoyed that I have to switch off wifi, then open group texts, then switch it back on - I've been just leaving data on.

With this setup I'm wondering if it will still prioritize data thru wifi when wifi is available?

Anyway, thank you for sharing this! 

2 Messages

no problem, glad to help