K

14 Messages

Sun, Oct 3, 2021 4:42 AM

Activation Incomplete - Internal Error (103)

I have a Samsung s10e I bought from Boost over a year ago.  For several days now I've noticed a high percentage of calls going straight to voicemail without the phone ringing. But I could still make calls as recently as yesterday.

Today I tried to make a call and it wouldn't connect. I rebooted the phone and got the error in my title: Activation Incomplete - Internal Error (103).

I CAN still send/receive text, and I still get mobile data. When people call me it goes straight to voicemail and I can check my messages in the voicemail app. I simply can't make or receive voice calls because "activation incomplete."

I've done everything you would think of resetting short of wiping the phone completely. I noticed that my last Android update was September 25, and I can't help but wonder if my current problems are related to that.

Boost Care

 • 

905 Messages

2 m ago

Hello Karl! We know this is frustrating! Please call us at 1-833-502-6678 to chat with us on boostmobile.com so our tech supports agents can assist you. 

14 Messages

@Ojay76 thanks, but my phone won't make calls,  and I've already spent two hours on chat support,  and already done a full factory reset. 

29 Messages

2 m ago

To get my s10e working on new network, it had to be unlocked for new SIM, and then i had to finish it by going to software update tab and clicking update UICC.  After that, it went onto TMobile LTE (Expanded Data Network).

14 Messages

@pdinnj yeah I dealt with the expanded network and unlocking last month. This month's issue is a new one. 

29 Messages

Ugh!  It kind of sounds like the network is losing track of you.  If your phone number and IMEI show correctly and SIM ICCD matches network registry, it should find you.  

Mobile network mode set to  LTE/3g/2g auto connect?  Reset network settings under general management?

Do you know how well covered you are with TMobile towers?  Where are you located?  There's an app called OpenSignal that is quite revealing for tower coverage.

29 Messages

@krefi i found this on Boost's FAQ:

If I’ve requested my device be unlocked, is there anything I should/should not do to ensure the unlock request processes?

The unlock request can take up to two business days to process for devices not currently under a BoostUP! installment plan. During that time, the following steps can help ensure the request processes properly:

Android Devices

  1. Ensure the SIM card remains in the device (removing or replacing the SIM card will cause the unlock request to fail)
  2. Ensure the device is powered on and within Boost Mobile network coverage area, or at minimum connected to a Wi-Fi network
  3. Upon receiving notification that the device is unlocked, check the UICC unlock, as follows:

    UICC Unlock: Go to Settings > System > System updates. UICC unlock or go to Settings and search for UICC Unlock. Tap UICC unlock for a settings refresh.

    If UICC unlock is not available, try updating the data profile as follows.

    Update Profile: Go to Settings > System > System updates > Update Data Profile

Please note: Performing an ##RTN# function on an Android device will re-lock the device to Boost Mobile.

14 Messages

@pdinnj Thanks, I'm fully unlocked, so no issue there. And I've done a full factory reset now.

(edited)

29 Messages

@krefi That's a bummer! My condolences. What a nuisance for you.

I wish Boist was handling this network switchover more smartly. If that doesn't work out, may be time to move on.

FWIW, the S10e is compatible with Mint Mobile and their monthly rates are lower than Boost.  Same TMobile LTE network.  They're cheaper, not sure they're smarter tech and customer support though.

14 Messages

2 m ago

Still struggling with this issue. The "activation not completed" notification is a permanent fixture on my phone now. But my ability to receive/send calls, and send/receive texts seems to come and go randomly.