Z

Wed, Oct 6, 2021 12:50 AM

Signal isn’t connecting pass 2 bars since I got the new expanded network sim card

I just bought the new expanded coverage SIM card yesterday and paid the $35 in store activation fee just to swap from my android to my iPhone to use it with boost and ever since I got the iPhone activated with the new SIM card I can barely get a signal and my iPhone keeps getting this prompt that my SIM card is trying to send me a text message constantly throughout the day. I spoke to customer support on my laptop for a while today and did everything they recommended like taking the SIM card out wiping it clean and putting it back in and resetting the network settings. None of these recommendations fixed either of my issues I still only have 1 to 2 bars of service in my house and before I switched to this new SIM card I had full bars most of the time in my house. We checked the coverage map and that wasn’t an issue. Each agent I exchanged messages with gave me the same recommendations each time and nothing worked. The last agent I exchanged messages with gave me a list of recommendations and then told me to call 611 with any other questions. Can anyone help me with this problem please? I’ve never ever had a nice phone and I finally got my hands on this iPhone 7 Plus and even paid the extra money to get this new SIM card and get it activated it’s really upsetting to finally have a nice phone and pay all that money just for my service to no longer work that well at all. 

Boost Care

 • 

905 Messages

2 m ago

Hello Zachary! We know this is frustrating for you. Please give us a call at 1-833-502-6678 so we can look into this further for you.