Joshapthorp22's profile

Sun, Mar 3, 2019 3:00 PM

New account; I paid my bill but service is still interrupted

Recently purchased this phone, I bought a $35 prepaid boost phone card for the $35 plan. I added the card successfully, it even shows its paid in my account. The auto message says my balance is 35 and I must pay $0 dollars and $0 cents in order to continue to use the service?! This is extremely irritating! Please help me correct this!

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Boost Care

 • 

807 Messages

2 y ago

Hi there! Really sorry to hear about this. We’d be happy to help. Please send us a private message with your phone number and pin code. 

4 Messages

2 y ago

I’m having the same problem and need customer service ASAP please

4 Messages

2 y ago

Okay I sent 2 private messages. One explaining the situation and the other with my phone number and PIN

Boost Care

 • 

3.2K Messages

2 y ago

@Lilnielsen7. We've received and replied to your private message. Please check your inbox.

4 Messages

2 y ago

I just had this exact same thing happen also and I can’t get ANY customer service!! On the phone on hold for 45 minutes and tried the chat and still waiting! I just want my new phone to work and for my service to start.

Boost Care

 • 

3.2K Messages

2 y ago

We definitely want to look into this for you, @Lilnielsen7. To research further, please send us a private message with your phone number and PIN.

To send a private message just click on the picture of any Boost Mobile agent and, in the next screen, click "send this user a private message".