cassieann204's profile

Sat, Oct 14, 2017 10:00 PM

my preowned samsung j3 emerge phone says i owe 0.00 but wont let me make calls or texts

i just made a payment. i went to call my friend and it said i needed to add 0.00 to my account before i could use it and that my account currently had 50.00 on it can you please help me.

Responses

Boost Care

 • 

905 Messages

4 y ago

Hello Cassieann204,  send me a private message so we can look into this for you.

3 Messages

3 y ago

Same thing is happening with my account as well except when i call its says i owe negative 1.00 to restore service

Boost Care

 • 

2.7K Messages

3 y ago

Hello Strongone! No worries! We definitely want to get this figured out for you ASAP. When did this issue first start? What type of phone do you have?

 

Boost Care

 • 

2.7K Messages

3 y ago

Our next step will be to update your data profile on your phone.

Step 1:From the home screen, tap Apps.

Step 2:Scroll to and tap Settings.

Step 3:Tap System Update. May be found under System section or General.

Step 4:Tap Update Profile.

Step 5:Once the profile update is complete, tap OK.

 

Please let us know how that worked out.

3 Messages

3 y ago

Saturday December 2nd i started service paid 36.00 for the 35.00 plan. My phone is a galaxy prevail lte prepaid

3 Messages

3 y ago

I did that a bunch of times. I reset the phone back to factory settings. It says profile updated but still nothing. It says my service is interrupted to pay 0.00 to restore service

Boost Care

 • 

2.7K Messages

3 y ago

Yikes! That’s no good. Let’s get this thing figured out. Can you please send us a private message with your phone number and PIN code so we can take a closer look?

 

3 Messages

3 y ago

I am having the same problem

3 Messages

3 y ago

How did they fix this issue? I am habing the same problem

Boost Care

 • 

944 Messages

3 y ago

Hey there! So sorry you're having issues. Have you tried doing a profile update? Do you also have a Samsung Galaxy J3?

1 Message

1 y ago

I too have the same problem. I have a pre-owned iPhone 6S and tried activating it about an hour ago but it wont work. Hoping someone could get back to me!

Boost Care

 • 

1.3K Messages

1 y ago

Oh no! Sorry to hear that, @Clayegg. We value your privacy and security. Due to the nature of your concern, we would like to authenticate your account, but for us to do this in a secure way we need to take this to a private channel where we can discuss private account information. Please send us a private message along with your phone number, the PIN and a brief description of your request. To send a private message, click on any of the social care agents user names and select the option send this user a private message.