User's profile

Wed, Jun 21, 2017 5:00 PM

Roaming

I payed the 5 dollar add on to use Data Roaming in mexico but i am unable to turn it on. It says "Data Roaming: you lost data connectively because you left your home network with data roaming turned off" i have a lg stylo 2

Responses

Accepted Solution

Boost Care

 • 

2.6K Messages

4 y ago

You'd have to activate the data services, including the one that's greyed out now.

Boost Care

 • 

2.6K Messages

4 y ago

If you do, then your roaming service seems to be working.

6 Messages

4 y ago

I have gone to setting but the "international data roaming" is greyed out and i am unable to turn it on. I restarted my phone several times and changed the network to GSM/UMTS but its still greyed out.

Boost Care

 • 

2.6K Messages

4 y ago

You can leave the network in automatic or LTE/CDMA.  The most probable reason for the lack of service is not having roaming coverage.

 

Please, visit this link and click "Mexico roaming" to check the coverage map:

 

https://www.boostmobile.com/#!/coveragemap/

 

.

6 Messages

4 y ago

I have service, when i turn on my phone it says movie star on the top left side and i have full bars and a R.

6 Messages

4 y ago

Thank You

6 Messages

4 y ago

Next time i travel what do i need to do as i thought after adding the add on, it would be activated automatically

6 Messages

4 y ago

I am currently connected to a wifi network but my phone data doesnt work. As i have an error saying "you have lost data connectively because you left your data nework with data roaming turned off" i am unable to turn it on as its greyed out.

Boost Care

 • 

2.6K Messages

4 y ago

Unfortunately, if the activation of the service didn't take place prior to traveling internationally, it could not be enable.

37 Messages

3 y ago

How do you enable greyed out settings? I am having similar issue with my S8...

Boost Care

 • 

1.3K Messages

3 y ago

Hi, kings_fan32! We would like to confirm with you, what are the grayed out settings on your device?

37 Messages

3 y ago

Domestic roaming is greyed out and is disabled... international roaming is not grayed out and enabled,, phone connects to Movistar in Mexico, but data can't connect...

Boost Care

 • 

1.3K Messages

3 y ago

Understood. Just shoot us a private message with the details, and we’ll take a closer look for you.

37 Messages

3 y ago

So International Mexico roaming works now... What fixed the issue, I have no clue... but I do know 3 things that occurred...
1) OTA Patch was released the weekend of November 18th...
2) My monthly payment was processed on the 22nd of November, maybe account refreshed, and roaming was updated on the Servers
3) ##BRAND# was keyed in while in the USA, When I entered Mexico yesterday Nov 25, received a txt msg, "Welcome to Boost I'ntl roaming, rather than Sprint roaming.... Data now works... Domestic roaming, does not yet work....

37 Messages

3 y ago

So, my S8 updated to Oreo, had the same issue while in Tijuana, solved the issue... you need to select the roaming network manually, meaning you need to search manually....In network, choose GMS/UMTS, then select network operators, and search manually... after a minute or so, you'll see a list, choose Movistar, it will then program itself, and you will end with the following Network: LTE/GSM/UMTS, which on my phone is not an option....