campbells0up's profile

Thu, Dec 31, 2020 10:00 PM

Can't swap to iPhone because of a firmware update.

Hello, if anybody could please help, it would be very much appreciated. I've been trying for hours to activate and swap to my new iPhone 11, but no matter how many times I try to factory reset or remove then put the SIM card back in, I always receive a message saying, "Firmware Update required. Be sure to update the firmware on the phone you are activating to ensure it works on the Expanded Network".  The iPhone is completely up to date so there are no updates that I can download. I've tried several times to set up the phone with the SIM card that came in the envelope to no avail. I've been looking through everyone else's experiences with this and it seems like there is no real answer. I've never had any problems swapping phones before, so I'm a bit at a loss. Any help is appreciated. Thank you.

Accepted Solution

3.6K Messages

1 y ago

Hey there @campbells0up Thank you for reaching out to us, and apologize for the inconvenience. Would you please be so kind to send us a Private Message, so we can further assist you?

 

To send a Private Message you can go to your profile and click on the icon with an envelope. Then you enter the username of the person you want to send a message to and the subject. Or you can go to the user profile by clicking on the username and click on "Send this user a Private Message". 

 

~JoyP.

 

 

1 Message

9 m ago

I faced similar kind of issue last time, I am still searching for some proper solution Same issue still no fix to this.

tellpizzahut.com

(edited)

Boost Care

 • 

2.1K Messages

Hello, Deluca. Thank you for stopping by. Please provide us more information about your issue to further assist you. 
- Kira_M

2 Messages

@DelucaCourt Did u ever end up getting this fixed? I am having the same problem. 

10 Messages

8 m ago

Same thing happened with me, Firmware is up to date but I still need to update it on my Iphone 11